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Using Cobalt™, Xenon™, Argon™



Ashlar-Vellum Cobalt, Xenon & Argon
Toaster Tutorial

This tutorial describes how to use Ashlar-Vellum's 3D modeling products Argon, Xenon, 
or Cobalt to create a simple toaster. As with any modeling program, there are infinite 
ways in which to create the same thing. The intent of this tutorial is to give an overview of 
the types of tools these programs provide and a base knowledge to begin creating your 
own models. It is understood that the user is somewhat familiar with the interface and 
knows how to use certain aspects of the program, such as rotating a view, the data entry 
fields, and simple window commands. The following tutorial was created in Cobalt, but it 
can also be done in Argon and Xenon.
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Setting up the Work Environment
When first opening the program all things such as where the windows are, units, and grid 
sizing are set to the default configuration. For this project, modify some of these settings 
to better suit the tutorial.

To change these settings go to File>Preferences.

The first thing to change is the Display resolution. Since the object being created is not 
very complex, set these all to the Highest setting and don’t worry about it slowing down 
the machine. If working on something with a higher detail, keep the settings at their 
defaults. Set the Curve, Surface, and Solid resolution to Super Fine.
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Next, adjust the Grid settings. Change the Sub-spacing to 2 and adjust the Grid Size to 
8. Also change the grid color to a dark gray. Doing this makes the XYZ axis on the 
screen a little more visible. Click Apply and OK.

Also change the setting for how the model looks on screen during the creation process. 
This is done by going to View>Shade Options. Change the Static Shade setting to 
Wireframe. This shows all the lines of the model while it is sitting still on the screen.
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It is usually best to organize the palettes on the screen to maximize the work area. Close 
the Design Explorer (it will not be used for this tutorial) and move the Trackball and Hide-
Show palette to the upper right corner to make more room for the model.

Before beginning to create the toaster, save the file as toaster on the computer.
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Creating the Toaster Body
The main toaster body is simply a block primitive with a profile trimmed off of the top.

1. Go to the Trimetric view (in drop-down list on the Trackball or simply press the 
letter g on the keyboard).

2. Turn on the grid using CTRL+G (Windows) or COMMAND+G (Macintosh).
3. Go to Windows>Snaps to open the Snaps palette and move it out of the 

center of the screen.
4. Turn on the To Grid snap option.

5. Select the Block Primitive tool.

6. In the Message Line, choose Block diagonals option.
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7. Starting at the origin select points 1 and 2.

8. Set the third point up in the z-direction. (It doesn't matter exactly where the 
point is put because the dimensions can be modified with the Status Line after 
the third point.)

9. After creating the block, enter data directly into the fields of the Status Line to 
achieve the exact size necessary.

10. Create a block that is 8 inches long, 4 inches wide, and 5 inches tall. To do this 
Type 8 into the L field, 4 into the W field, and 5 into the H field. Click ENTER. 
The block will update to these values.

11. Turn the Grid off using CTRL+G (Windows) or COMMAND+G (Macintosh).
12. Go to the front view (S is the shortcut). Zoom out to see the block just created. 

To do this either zoom out: CTRL+[ (Windows) or COMMAND+[ (Macintosh), 
or zoom all: CTRL+F (Windows) or COMMAND+F (Macintosh).
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13. Use SHIFT+CTRL (Windows) or COMMAND (Macintosh) to draw a 
construction line off the top of the block. This shortcut is done by pressing the 
SHIFT+CTRL keys (Windows) or the COMMAND key (Macintosh) selecting 
the point where the construction line is to be and dragging the cursor up, down, 
left, or right depending on which direction the line should be.)

14. Turn off the To Grid in the Snaps options palette.

15. Use the Parallel Line tool and drag the construction line 
down and type .375 and ENTER.

16. Select the 3-point Arc tool and create an arc at the shown 
points.

17. Go to the Trimetric view (G is the shortcut).
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18. Select the Trim Solid tool and in the Message Line options, use the 
Specify Vector option.

19. Select the first point of the vector to be at one of the endpoints of the arc 
(Point 1).

20. Using the Drafting Assistant, select the other at some point along the Y-axis 
(Use Drafting Assistant)
(Point 2).

21. Select the arc, then select the block.
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22. If the wrong part of the solid is gone, press the CTRL (Windows) or OPTION 
(Macintosh) key to toggle between parts of the solid to trim.

23. This should be what the model looks like at the end of this section.

24. Save the file.
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Creating the Toaster Base
Creating the toaster base is simple. Create a profile off of the bottom of the block. Off of 
this profile, extrude it upward to make the base. By using the Draft Angle feature of the 
Extrude Solid tool we can taper the edge of the base at the same time we extrude it.

1. Select the Offset Curve tool.
2. Type .25 in the Offset field in the Status Line.

3. While holding the SHIFT key, select the four bottom edges of the block, then 
release the SHIFT key.

4. Hold the CTRL (Windows) OPTION (Macintosh) key and select an area 
outside of the block.
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5. Select the Extrude Solid tool in the Solids Tool palette. 

6. Make sure the Work Plane snap is turned off
7. Select the four lines that were just offset. (To easily do this using the chain 

select, hold the SHIFT key while selecting the first line. Then while continuing 
to hold the SHIFT key, press the ~ key (Windows) or COMMAND + ~ (Mac) to 
automatically select all the lines connected in the chain.)

8. Select one of the corners of the rectangle just selected for the first point.
9. Select a point up in the z-direction to define an extrusion direction.

10. Type in .5 (for the Distance) and –5 (for the Draft Angle), and press ENTER.
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11. Select the Blend tool from the Solids Tool palette.

12. Make sure that the options for the tool are set for Constant blend and a 
Radial.

13. Type .125 the Radius and press ENTER.
14. Select the eight edges shown in bold red while holding the SHIFT key. 

15. While this tool is active, go ahead and round over the edges of the toaster 
body.

16. Type .375 in the Radius Field.
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17. Select the edges of the toaster body shown in bold red while holding the 
SHIFT key.

18. Deselect the Blend tool.
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19. At the end of this section the model should look like this.

20. Save the file.
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Creating the Toaster Slots
In order to create the slots for the toaster, create a block, place it and a copy in the 
position where the slots would be, and subtract the two blocks from the main body.

1. Select all of the objects and Hide them. (To do this quickly by press CTRL+ A 
(Windows) or COMMAND+A (Macintosh) and selecting the Hide from the 
Hide-Show palette. Turn on the Grid using CTRL+G (Windows) OPTION+G 
(Macintosh)

2. In the Snaps palette, turn on the To Grid snap and turn off the Work Plane 
snap.

3. Select the Block Primitive tool with Block Diagonals option.
4. Draw a block with the first point at the origin (point 1) and the second at point 2 

and the last up in the z-direction

5. Type 5 in the L field, 1 in the W field, and 6 in the H field. (This sets the length 
to 5, the width to 1 and the height to 6). Press ENTER.

6. Select the Show All button from the Show-Hide palette
7. Go to the top view using shortcut key D.



Cobalt, Xenon & Argon Toaster Tutorial
8. Turn on the Work Plane snap back.

9. Select the Move Tool. 
10. Select the slot block.
11. Pick the point at the lower left hand corner of the block.
12. Select the next point somewhere near the lower middle of the toaster.

13. Type 1.36 in to the dX (change in X) field, .5 into the dY field, and .25 into the 
dZ field and press ENTER. (This sets the distance moved in the X, Y, and Z 
coordinates. By typing in these exact values be assured that the block is in the 
same place as in the picture.)

14. Hold the CTRL key (Windows) or the OPTION key (Macintosh) to select the 
same corner of the rectangle as earlier and move up in the y direction around 2 
inches.
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15. Type 2 into the dY field and make sure the other fields have 0 in them. (This 
will set the distance move in the Y direction to 2 inches). Press ENTER.

16. Go to the Trimetric view using shortcut key G.
17. Select the Subtract Solid tool from the Solids tool palette.

18. Select the toaster body.
19. Hold the SHIFT key and select the two blocks just made.
20. Release the SHIFT key.

21. Select the Radial Blend tool. 
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22. Type .125 in the R field of the Status Line and press ENTER.
23. While holding the SHIFT key, select the eight edges shown in the picture. 

Release the SHIFT button. The selected edges of the block get rounded.

24. Do the same thing to the eight other edges from the other slot.
25. At the end of this section the model should look like this.

26. Save the file.
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Creating the Switch
To create the switch and the slot for the switch, use some of the same methods that were 
used earlier to create the parts.

1. Deselect the Work Plane snap option.

2. Select the Rectangle tool from the main tool palette. 
3. In the Message Line select the Rectangle by Center and Corner Point option.

4. For the first point (the center), select the point on the base(#1) at the midpoint, 
the Drafting Assistant is very handy for this. The second is arbitrary since the 
necessary value can be typed in Status Line.

5. Type 10 for the width and .25 for the length and press ENTER.
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6. Select the Extrude Solid tool from the Solids Tool palette.

7. Select the four lines that were just created. (To easily do this using the chain 
select, hold the SHIFT key while selecting the first line. Then while continuing 
to hold the SHIFT key, press the ~ key (Windows) or COMMAND + ~ (Mac) to 
automatically select all the lines connected in the chain.)

8. Release the SHIFT key. 
9. Select one of the corners of the rectangle just selected for the first point.
10. Select a point up in the z-direction to define an extrusion direction, use the 

Drafting Assistant to help.
11. Type 2 into the Distance field. Press TAB to go to the Draft Angle field. Enter 0 

for that value and press ENTER.

12. Select the Subtract Solid tool from the Solids tool palette.
21



Ashlar-Vellum Toaster Tutorial

22
13. Select the toaster body, then the small block just created.
14. In the menu bar, go to Planes>Side. This will create all new geometry on the 

side plane. The view will not look any different.

15. Select the 2-point Center Ellipse tool.
16. Click on point 1. near the midpoint of the top of the slot that was just created). 

Point 2 is arbitrary since the value for it will be entered into the Status Line data 
fields.

17. Enter .375 into the L1 field and .125 into the L2 field. Press ENTER.
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18. Select the Extrude Profile tool.

19. Select the ellipse.
20. Click the first point at the ellipse and the second point away from the ellipse 

along the z-axis.

21. Type .375 for the Distance, press the TAB key, type -3 (for the Draft Angle), 
press ENTER.

22. Zoom all using CTRL + F (Windows) or COMMAND+ F (Macintosh).
The toaster is completed except for photo rendering.

23. To see the parts a little more distinctly, change the color of the toaster body. To 
do this, choose the Select tool, highlight the toaster body, go to Pen (or right 
mouse click), and select a different color.

24. Save the file.
23



Ashlar-Vellum Toaster Tutorial

24
25. Go to Photo Render>Raytrace Render to see the results.

26. Call your Mom, tell her you learned how to do 3-D modeling. She may not 
know what you mean, but she will be proud.
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